Ellipse question - International Association of Penturners
     International Association of Penturners
Pens for Service Members
 
Support The IAP

Go Back   International Association of Penturners > IAP Marketplace > Vendor Forums > ExoticBlanks.com -corner of IAP!!
  Forgot Password
Register FAQ Members List Search Today's Posts Mark Forums Read


Logged on members can hide ads!

Welcome to penturners.org!

You've found the home of The International Association of Penturners. You are currently viewing our site as a guest, which gives you limited access to view discussions, photos, and library articles.

Consider joining our community today. You'll have full access to all of our content, be able to enter our contests, find local chapters near you, and post your questions and share your experience with our members all over the world.

Membership is completely free!!

If you have any problems with the registration process or your account login, please contact us.

Reply
 
LinkBack Thread Tools Display Modes
Old 01-23-2018, 04:12 PM   #1 (permalink)
 
Join Date: Mar 2017
Location: Houston, Texas
Photos: 12

Default Ellipse question

I have had this Ellipse pen in the drawer for a couple of months, I played with it or showed it to people every couple of weeks with no issues (i.e. some, but not much use). Last night I went to package it up as a birthday gift and I couldn't get the refill to extend, the upper and lower sections were just slipping almost freely. I exercised the transmission a bit, but no luck. Finally I decided to put a little loctite on the transmission (where it friction fits) and this did the trick. From the beginning, the friction fit of the transmission seemed loose, but early on it worked ok without too much slippage. Is this a common issue? Did I do something wrong?
Attached Thumbnails
psx_20171117_175501.jpg  
__________________
--Sam
Dehn0045 is offline   Reply With Quote Top
Old 01-23-2018, 09:01 PM   #2 (permalink)
Local Chapter Manager
 
ed4copies's Avatar
 
Join Date: Mar 2005
Location: Racine, WI, USA.
Posts: 23,401
Photos: 27

Default

Hi Sam,

This is the first time I have heard of a transmission slipping.

Actually, I had a couple hundred extras made, when the pen was produced (an ounce of preparedness), I have no idea where they are, I have only replaced one other transmission, it was bad from the get-go.

Happy to send you a replacement, just request it in the comments of your next order.

Ed
__________________
Ed Brown
ed4copies is offline   Reply With Quote Top
Old 01-23-2018, 10:52 PM   #3 (permalink)
 
Join Date: Mar 2017
Location: Houston, Texas
Photos: 12

Default

Thanks for the response Ed, good to hear that it isn’t a common issue, might have been something I did, who knows. I have a few more of these kits (stupid me, I didn’t try one of the other transmissions before the blue thread lock). I’ll let you know if I have any similar issues with the remaining kits
__________________
--Sam
Dehn0045 is offline   Reply With Quote Top
Advertisement
Related Content
Logged on members can hide ads
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 01:37 PM.

Powered by vBulletin® Version 3.7.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0

Content Copyright © 2003-2018 by Penturners.org, LLC; All Rights Reserved
Terms Of Service   Acceptable Use Policy